Need to Register?

Currently you can register through a Gmail, Facebook, or OpenID account. This helps us avoid spam. Click an icon below! :)

Sign In with Facebook Sign In with Google Sign In with OpenID

Origin Help

As the title says I am having some origin trouble.

I got a new mobo, chip and ram on boxing day. A few days later put it together and did a fresh windows install.

After downloading and installing the current version of origin. When I open origin the login screen opens, I can put in my username and password. When I hit login origin minimizes to the bottom right corner of my screen in the windows bar (systems tray?). The origin window doesn't open and I can't right or left click the origin symbol in the bottom right at all. Even ending the process and restarting don't do anything either. The strange thing is even if I end the origin process and try to shutdown windows or restart the shutdown screen just hangs for over 10 minutes and I end up shutting my PC down manually. Like origin or something else is hanging up in the background. This shut down issue only happens after or when I have origin run on that current session of windows. If I haven't ran origin my PC will shutdown or restart just fine.

I have read and tried many things on google and youtube but can't seem to find anything about this specific issue.

I have tried:

Fresh windows install
Older versions of origin and doing the updates
Did a print screen of task manager and ran origin and looked at task manager but can't seem to see any odd programs running

Any help would be appreciated I'm at my wits end with this currently waiting on my origin ticket to be answered :(

Chowner

Comments

  • Is the window visible in the peek on the taskbar? Is it possible that it's just shifted off-screen?
    If so, try this trick:

    Hover over the icon int he task bar to get the peek, right click the window and pick 'move' then hit an arrow key to attach the window to the mouse.. Then move it wherever you like.

    Alternatively, not being able to interact with the tray toolbox sounds like the process is blocking, possibly user input on a 'would you like to install the latest update?' or something like that? In this case, you could grab a tool like spy++ to see if you can track down the window, or you can try making sure everything is closed and then launch origin, login and when it minimizes, just try hitting the space bar, or enter, or some other 'accept' type of button to see if it happens to have the correct window in focus just hidden out of view somewhere.

    Failing that...... Origin sucks. :P
  • fun fact, Origin currently doesn't load for me at all but gives me this error:

    Well, that didn't go as planned

    Origin encountered an issue loading this page. Please try reloading it – if that doesn’t work, restart the client or try again later.
Sign In or Register to comment.

USDN.CA does not support IE8 or less. Things may not look good or work at all. Why aren't you using a modern browser? :)